Browser Compatibility for Kentucky.gov

 
Browser Compatibility for Kentucky.gov
Kentucky.gov websites and supported applications are best viewed in the most recent version of any of the following browsers:
•  Chrome
•  Firefox
•  Internet Explorer
•  Safari
Users may view our sites and applications in older versions, but may not experience the same level of functionality. Kentucky.gov products adhere to WC3 standards, are built to be ADA compliant and accessible from a variety of devices, including phones, tablets and desktops.  

Attachments

Browser_Compatibility_for_Kentucky.pdf Browser_Compatibility_for_Kentucky.pdf

Did you find this article helpful?